home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / aircrack-ng-0.5 / aircrack-ng-0.5.ebuild next >
Text File  |  2006-05-10  |  687b  |  26 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/aircrack-ng/aircrack-ng-0.4.ebuild,v 1.3 2006/04/24 13:18:10 josejx Exp $
  4.  
  5. inherit toolchain-funcs eutils
  6.  
  7. DESCRIPTION="WLAN tool for breaking 802.11 WEP keys"
  8. HOMEPAGE="http://www.aircrack-ng.org"
  9. SRC_URI="http://download.aircrack-ng.org/${P}.tar.gz"
  10.  
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~ppc ~x86"
  14. IUSE=""
  15.  
  16. DEPEND="net-libs/libpcap"
  17.  
  18. src_compile() {
  19.     emake -e CC="$(tc-getCC)" || die "emake failed"
  20. }
  21.  
  22. src_install() {
  23.     make prefix=/usr docdir="/usr/share/doc/${PF}" destdir="${D}" install \
  24.         || die "make install failed"
  25. }
  26.